Home | Advertising Info239 USERS CURRENTLY ONLINE   
PowerASP
   Site Search Contact Us Friday, November 15, 2019  

  Active InfoActive Info  Display List of Info MembersMemberlist  Search The InfoSearch  HelpHelp
  RegisterRegister  LoginLogin
Technology Talk
 PowerASP Code Help Area : Technology Talk
Subject Info: Timeout Error A d d  -  P o s tAdd P o s t
Author
Message << Prev Info | Next Info >>
sriramnatesan
Newbie
Newbie
Avatar

Joined: November/15/2005
Location: India
Online Status: Offline
Info: 2
Added: November/15/2005 at 5:19am | IP Logged Quote sriramnatesan

My ASP page has script timeout of 900 seconds. The ADO command and connection timeout in the COM is also 900 seconds. Until last week, it seemed to be working fine. But since yesterday it gives me a timeout error well before 5 minutes. There seems to be an erratic behavior. It suddenly works fine and then it does not (all this happens without any code change).

I checked the IIS settings, it shows the timeout setting as 900 seconds. I even checked the SQL Query timeout which is 0.

I then tried changing the timeout to 0 in the COM. I had kept a WAITFOR DELAY '00:15:00' statement in my stored procedure used. It was working fine even despite the delay of 15 minutes. There was no timeout error.

Can anybody throw light on why such an erratic behavior? What can be the issue and how can I address the same?

The task is very critical on the business point of view and cannot throw a timeout error.

Kindly reply in this forum or reply to sriram_natesan@infosys.com

Thanks in Advance,

Sriram

Back to Top View sriramnatesan's Profile Search for other info by sriramnatesan
 
sriramnatesan
Newbie
Newbie
Avatar

Joined: November/15/2005
Location: India
Online Status: Offline
Info: 2
Added: November/15/2005 at 6:25pm | IP Logged Quote sriramnatesan

to make it more clear for what I am looking for:

We know that override of default timeout can be done through having script timeout value overridden in the ASP page (set to 900)

And have commandTimeout and Connectiontimeout properties set in the Com layer (we are using ADO)

The problem is that this code works fine in some servers but does not in other servers.

All the articles/posts point to default timeout values being overridden by the setting done above but we donít know what can override

These settings.

Obviously, this seems to be some server/IIS setting /environment issue rather than a code level issue since it should not have worked in one server and not on the other.

Back to Top View sriramnatesan's Profile Search for other info by sriramnatesan
 

If you wish to make a comment to this info you must first login
If you are not already registered you must first register

  A d d  -  P o s tAdd P o s t
Printable version Printable version

Info Jump
You cannot add new info in this area
You cannot add to info in this area
You cannot delete your info in this area
You cannot edit your info in this area
You cannot create polls in this area
You cannot vote in polls in this area

   Active Server Pages Rule The World
Contact Us  
All artwork, design & content contained in this site are Copyright © 1998 - 2019 PowerASP.com and Christopher J. Williams
Banner ads ,other site logos, etc are copyright of their respective companies.
STATS Unless otherwise noted - All Rights Reserved.

Active Server Pages what is asp programming how to sample asp example code scripts software asp forum mail sessions applications global.asa CJWSoft ASPProtect ASPBanner ASPClassifieds www.aspprotect.com, www.cjwsoft.com,www.aspclassifieds.com,www.aspphotogallery.com